Yep, It’s a Problem …

From Readers who’ve had all the problems you’ve heard about with …

This is not necessarily, actually definitely not, a representative sample of reader responses. But since I’ve posted emails from readers who’ve had a relatively workable experience I wanted to include a number from readers (most of whom are pretty clearly supporters of the law) who’ve had just about as bad an experience as you’ve heard about.

From TPM Reader GM

I went through the process today as if my family and I needed coverage. I have four children, and my wife and I are both teachers so we have employer plan coverage. The form was pretty easy, if repetitive. I did it while reviewing research paper outlines at the same time. Not complicated. I’m in Nebraska, so obviously my state is doing everything it can to make the process not work. I reached the end. Twice. It said that after I verified my identity I would see plans to choose from. Both times, I was sent to my settings page where my name had a green verified checkmark by it, but there was no green continue button. When I went back to my applications it said I was “in progress” but I could never get beyond that to see any plans. I wanted this to work, so I could walk my brothers through this. They really need affordable coverage and I think they will qualify for subsidies. One has no insurance and just never seeks care. The other has had issues and has bare-bones, expensive coverage. What I saw today doesn’t make me want to bring them in yet. On the help chat they said I should have seen plans. I didn’t.


From TPM Reader ES

I’ve had a TERRIBLE time trying to get the website to work, here in Austin Texas. Two of my employees in Minnesota have also had a very difficult time getting the website to work, although I don’t think they’ve put as much time into it as I have.

I am trying to find individual rates, to compare against our current group plan (which I pay 100% of for my employees). I only have four employees, and we’re in two different states. This means that our group plan isn’t very competitive.

I am not exaggerating — I have tried to logon to the website at least 12-15 times in October. The first week I simply couldn’t get past some major website errors, such as blank pull-down menus and submission buttons that wouldn’t progress to the next step.

Since the initial week, I’ve been able to get a bit further into the website. I have set up three entirely separate accounts, and have failed to authenticate my identity on two of them (the health care website seemed to generate errors when communicating with Experian, thus failing the identity check). My manual attempts to verify my identity, by sending a photo of my ID and social security card, also failed twice.

On my third attempt to create an account, I have been able to successfully verify my identity, but I have still not received any information on health care plans. My application is still shown as ‘In Progress’ and hasn’t advanced past this point for two days.

I will probably have to resort to calling in by phone next week, but I was hoping to avoid the (expectedly) long phone queue and get this done electronically.

This is a terrible, terrible website rollout. The website has been completely non-functional for its intended purpose for over three weeks.

I say this as someone who has created and managed a hand-coded ecommerce website for over 15 years. If I can’t figure this out, then I don’t imagine that others are having much success either.


From TPM Reader BD …

I’m in the Houston,Texas area. I and my employees have insurance through my employer provided plan. Wanted to see what kind of insurance I could get through the exchange. With my income,it’s doubtful that I qualify for any subsidies. I also wanted to try to help my girlfriend get health insurance. She probably will qualify for a subsidy. Went to the website and created an account Saturday night. It is a mess. I tried to fill out an application. Wanted to use my work number as my primary phone number and my cell # as my secondary number. Keyed the numbers in the appropriate blanks. When I had completed the application and had to review it before signing it,it had my cell # as my primary number and my work number as my secondary/residential number. Tried twice to edit that and add my middle name to my account since that is also on my SS card. Each time,I changed the info and went to review my app it did not show it to be changed. Tried a 3rd time. By the time I got to the end of the process,the website was down. As Josh would say,”fuck that”. I did get an email that night confirming that I had successfully created an account. Haven’t been back to the site since then.